comparison hgext/mq.py @ 37262:54435fd09f1d

clone: rename "rev" to "revs" since there can be many It was a little tricky in hg.clone(), since there was a local "revs" variable defined there, but "rev" was never used after "revs", so I just overwrote it. Note that clonewithshare() should also have its "rev" argument renamed to "revs", but I'll leave that to someone else. Differential Revision: https://phab.mercurial-scm.org/D3016
author Martin von Zweigbergk <martinvonz@google.com>
date Mon, 02 Apr 2018 08:46:07 -0700
parents f0b6fbea00cf
children 76823340a899
comparison
equal deleted inserted replaced
37261:3809eafedf2c 37262:54435fd09f1d
2503 pass 2503 pass
2504 2504
2505 ui.note(_('cloning main repository\n')) 2505 ui.note(_('cloning main repository\n'))
2506 sr, dr = hg.clone(ui, opts, sr.url(), dest, 2506 sr, dr = hg.clone(ui, opts, sr.url(), dest,
2507 pull=opts.get('pull'), 2507 pull=opts.get('pull'),
2508 rev=destrev, 2508 revs=destrev,
2509 update=False, 2509 update=False,
2510 stream=opts.get('uncompressed')) 2510 stream=opts.get('uncompressed'))
2511 2511
2512 ui.note(_('cloning patch repository\n')) 2512 ui.note(_('cloning patch repository\n'))
2513 hg.clone(ui, opts, opts.get('patches') or patchdir(sr), patchdir(dr), 2513 hg.clone(ui, opts, opts.get('patches') or patchdir(sr), patchdir(dr),