comparison hgext/git/dirstate.py @ 49961:7a8bfc05b691

dirstate: rename parentchange to changing_parents Since the new argument breaks the API anyway, we can rename it to a better name. The previous name `parentchange` might be seen as something active, a function that would directly change the parents, however this is just a context manager to frame the operation that will change the parents and adjust the dirstate content accordingly. In addition, the future sister method that will be about changes to tracking and files would have a hard time fitting in the same naming scheme in a clear way. The new naming uses a clear prefix will make it more distinct from other dirstate methods and easier to extend with other similar contexts.
author Pierre-Yves David <pierre-yves.david@octobus.net>
date Wed, 25 Jan 2023 19:12:31 +0100
parents c166b212bdee
children e333cc169c45
comparison
equal deleted inserted replaced
49960:c166b212bdee 49961:7a8bfc05b691
382 def update_file(self, *args, **kwargs): 382 def update_file(self, *args, **kwargs):
383 # TODO 383 # TODO
384 pass 384 pass
385 385
386 @contextlib.contextmanager 386 @contextlib.contextmanager
387 def parentchange(self, repo): 387 def changing_parents(self, repo):
388 # TODO: track this maybe? 388 # TODO: track this maybe?
389 yield 389 yield
390 390
391 def addparentchangecallback(self, category, callback): 391 def addparentchangecallback(self, category, callback):
392 # TODO: should this be added to the dirstate interface? 392 # TODO: should this be added to the dirstate interface?