comparison contrib/debian/rules @ 26148:7f49efcaa9b4

debian: switch to using debhelper and dh_python2 to build debs This is a much larger commit than I'd like, but I honestly don't see a good way to break it up and leave things working. Summary: We now use debian/rules with debhelper to build our debs. This is much more standard, and means we use dh_python2 to do things like handle leaving .pyc files out of the built debs. The resulting package is split into mercurial and mercurial-common, with the former being the hg stub and all the native .sos, and the latter being basically everything else. builddeb and dockerdeb are updated to use the new system. The old way (using dpkg by hand) breaks with the above changes because debian/control no longer contains a version string (that's now guessed from the phony changelog.) Tests are updated to assert that the right files end up in the right debs.
author Augie Fackler <augie@google.com>
date Wed, 26 Aug 2015 10:59:09 -0400
parents
children 9cecbe837c94
comparison
equal deleted inserted replaced
26147:a02c22e48142 26148:7f49efcaa9b4
1 #!/usr/bin/make -f
2 # Uncomment this to turn on verbose mode.
3 # export DH_VERBOSE=1
4
5 CPUS=$(shell cat /proc/cpuinfo | grep -E ^processor | wc -l)
6
7 %:
8 dh $@ --with python2
9
10 override_dh_auto_test:
11 http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)"
12
13 override_dh_python2:
14 dh_python2
15 find debian/mercurial/usr/share -type d -empty -delete
16
17 override_dh_install:
18 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial --install-layout=deb
19 # remove arch-independent python stuff
20 find $(CURDIR)/debian/mercurial/usr/lib \
21 ! -name '*.so' ! -type d -delete , \
22 -type d -empty -delete
23 python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial-common --install-layout=deb
24 make install-doc PREFIX=$(CURDIR)/debian/mercurial-common/usr
25 # remove arch-dependent python stuff
26 find $(CURDIR)/debian/mercurial-common/usr/lib \
27 -name '*.so' ! -type d -delete , \
28 -type d -empty -delete
29 rm $(CURDIR)/debian/mercurial-common/usr/bin/hg