diff rust/hg-core/Cargo.toml @ 46390:0800aa42bb4c

rust: use the bytes-cast crate to parse persistent nodemaps This crate casts pointers to custom structs, with compile-time safety checks, for easy and efficient binary data parsing. See https://crates.io/crates/bytes-cast and https://docs.rs/bytes-cast/0.1.0/bytes_cast/ Differential Revision: https://phab.mercurial-scm.org/D9788
author Simon Sapin <simon.sapin@octobus.net>
date Fri, 15 Jan 2021 16:11:54 +0100
parents 3aec2620554b
children 645ee7225fab
line wrap: on
line diff
--- a/rust/hg-core/Cargo.toml	Mon Jan 25 19:03:27 2021 -0500
+++ b/rust/hg-core/Cargo.toml	Fri Jan 15 16:11:54 2021 +0100
@@ -9,6 +9,7 @@
 name = "hg"
 
 [dependencies]
+bytes-cast = "0.1"
 byteorder = "1.3.4"
 hex = "0.4.2"
 im-rc = "15.0.*"