--- a/setup.py Thu Sep 22 15:15:18 2011 +0200
+++ b/setup.py Tue Sep 20 15:21:27 2011 +0300
@@ -366,7 +366,7 @@
extmodules.append(Extension('mercurial.osutil', ['mercurial/osutil.c'],
extra_link_args=osutil_ldflags))
-if sys.platform == 'linux2' and os.uname()[2] > '2.6':
+if sys.platform.startswith('linux') and os.uname()[2] > '2.6':
# The inotify extension is only usable with Linux 2.6 kernels.
# You also need a reasonably recent C library.
# In any case, if it fails to build the error will be skipped ('optional').