diff setup.py @ 41533:0f64091cc851

global: make some docstrings raw strings Python 3.8 emits a SyntaxWarning when a str/bytes contains invalid \ escapes. Various docstrings in our code base contain invalid \ escapes. This commit turns those docstrings into raw strings. Differential Revision: https://phab.mercurial-scm.org/D5816
author Gregory Szorc <gregory.szorc@gmail.com>
date Mon, 04 Feb 2019 09:07:00 -0800
parents 8427fea04017
children aaad36b88298
line wrap: on
line diff
--- a/setup.py	Mon Feb 04 08:54:30 2019 -0800
+++ b/setup.py	Mon Feb 04 09:07:00 2019 -0800
@@ -666,7 +666,7 @@
             self.addlongpathsmanifest()
 
     def addlongpathsmanifest(self):
-        """Add manifest pieces so that hg.exe understands long paths
+        r"""Add manifest pieces so that hg.exe understands long paths
 
         This is an EXPERIMENTAL feature, use with care.
         To enable long paths support, one needs to do two things: