diff setup.py @ 10761:16a13fdb4b36 stable

setup: fail if bz2 is not available
author Dirkjan Ochtman <dirkjan@ochtman.nl>
date Tue, 23 Mar 2010 20:01:30 +0100
parents bde1bb250fc2
children 95b7a15b2f05
line wrap: on
line diff
--- a/setup.py	Mon Mar 22 22:19:40 2010 +0100
+++ b/setup.py	Tue Mar 23 20:01:30 2010 +0100
@@ -26,6 +26,12 @@
     raise SystemExit(
         "Couldn't import standard zlib (incomplete Python install).")
 
+try:
+	import bz2
+except:
+	raise SystemExit(
+		"Couldn't import standard bz2 (incomplete Python install).")
+
 import os, subprocess, time
 import shutil
 import tempfile