diff setup.py @ 7056:2c1f18b88b6a

osutil: implementation for Win32 Use information provided by FindFile... Win32 calls to generate stat information without lstat call per file. rwx bits in st_mode are ignored as they are not stored in Win32 fs and Mercurial does not use them Unicode path / path names over _MAX_PATH are intentionally not supported.
author Petr Kodl <petrkodl@gmail.com>
date Sun, 14 Sep 2008 09:57:33 -0400
parents 8fee8ff13d37
children 2fdbf2ccd03a
line wrap: on
line diff
--- a/setup.py	Mon Sep 29 09:30:36 2008 +0200
+++ b/setup.py	Sun Sep 14 09:57:33 2008 -0400
@@ -102,6 +102,12 @@
             'hgext.highlight']
 
 try:
+    import msvcrt
+    ext_modules.append(Extension('mercurial.osutil', ['mercurial/osutil.c']))
+except ImportError:
+    pass
+
+try:
     import posix
     ext_modules.append(Extension('mercurial.osutil', ['mercurial/osutil.c']))