--- a/setup.py Wed Sep 21 11:44:08 2005 -0700
+++ b/setup.py Wed Sep 21 13:33:24 2005 -0700
@@ -13,13 +13,13 @@
# py2exe needs to be installed to work
try:
- import py2exe
+ import py2exe
# Due to the use of demandload py2exe is not finding the modules.
- # packagescan.getmodules creates a list of modules included in
+ # packagescan.getmodules creates a list of modules included in
# the mercurial package plus depdent modules.
- import mercurial.packagescan
- from py2exe.build_exe import py2exe as build_exe
+ import mercurial.packagescan
+ from py2exe.build_exe import py2exe as build_exe
class py2exe_for_demandload(build_exe):
""" overwrites the py2exe command class for getting the build
@@ -34,7 +34,8 @@
# Sets the 'includes' option with the list of needed modules
if not self.includes:
self.includes = []
- self.includes += mercurial.packagescan.getmodules(self.build_lib,'mercurial')
+ self.includes += mercurial.packagescan.getmodules(self.build_lib,
+ 'mercurial')
build_exe.finalize_options(self)
except ImportError:
py2exe_for_demandload = None