setup.py
changeset 51848 3f0db3b6bf14
parent 51836 905bc9d0a149
child 51849 4dc1fc2b2f3a
--- a/setup.py	Wed Sep 11 00:20:07 2024 +0200
+++ b/setup.py	Thu Sep 05 16:59:36 2024 -0400
@@ -1654,27 +1654,6 @@
         pass
 
 
-if os.name == 'nt':
-    # Allow compiler/linker flags to be added to Visual Studio builds.  Passing
-    # extra_link_args to distutils.extensions.Extension() doesn't have any
-    # effect.
-    try:
-        # setuptools < 65.0
-        from distutils import msvccompiler
-    except ImportError:
-        from distutils import _msvccompiler as msvccompiler
-
-    msvccompilerclass = msvccompiler.MSVCCompiler
-
-    class HackedMSVCCompiler(msvccompiler.MSVCCompiler):
-        def initialize(self):
-            msvccompilerclass.initialize(self)
-            # "warning LNK4197: export 'func' specified multiple times"
-            self.ldflags_shared.append('/ignore:4197')
-            self.ldflags_shared_debug.append('/ignore:4197')
-
-    msvccompiler.MSVCCompiler = HackedMSVCCompiler
-
 packagedata = {
     'mercurial': [
         'configitems.toml',