diff rust/hg-cpython/Cargo.toml @ 46588:47557ea79fc7

copies-rust: move CPU-heavy Rust processing into a child thread … that runs in parallel with the parent thread fetching data. This can be disabled through a new config. CLI example: hg --config=devel.copy-tracing.multi-thread=no For now both threads use the GIL, later commits will reduce this. Differential Revision: https://phab.mercurial-scm.org/D9684
author Simon Sapin <simon.sapin@octobus.net>
date Wed, 06 Jan 2021 14:09:01 +0100
parents e604a3c03ab9
children c7c6c11fe1e4
line wrap: on
line diff
--- a/rust/hg-cpython/Cargo.toml	Tue Jan 05 21:02:00 2021 +0100
+++ b/rust/hg-cpython/Cargo.toml	Wed Jan 06 14:09:01 2021 +0100
@@ -22,6 +22,7 @@
 python3-bin = ["cpython/python3-sys"]
 
 [dependencies]
+crossbeam-channel = "0.4"
 hg-core = { path = "../hg-core"}
 libc = '*'
 log = "0.4.8"