diff setup.py @ 44485:5cbe2c0ebc53

setup: use printf instead of print Yuya Nishihara pointed `printf` to me, so I will respect the cargo cult.
author Pierre-Yves David <pierre-yves.david@octobus.net>
date Mon, 09 Mar 2020 17:16:44 +0100
parents ad718271a9eb
children 06b0aa048007
line wrap: on
line diff
--- a/setup.py	Mon Mar 09 11:18:33 2020 -0700
+++ b/setup.py	Mon Mar 09 17:16:44 2020 +0100
@@ -3,8 +3,6 @@
 #
 # 'python setup.py install', or
 # 'python setup.py --help' for more options
-from __future__ import print_function
-
 import os
 
 # Mercurial will never work on Python 3 before 3.5 due to a lack
@@ -143,7 +141,7 @@
 # (see mercurial/__modulepolicy__.py)
 if hgrustext != 'cpython' and hgrustext is not None:
     if hgrustext:
-        print('unkown HGWITHRUSTEXT value: %s' % hgrustext, file=sys.stderr)
+        printf('unkown HGWITHRUSTEXT value: %s' % hgrustext, file=sys.stderr)
     hgrustext = None
 
 import ctypes