diff hgext/histedit.py @ 37678:5f8f013e7d52

scmutil: rename resolvepartialhexnodeid() to resolvehexnodeidprefix() I'm going to wrap revlog.shortest() in scmutil. I plan on calling it shortesthexnodeidprefix(). resolvehexnodeidprefix() matches that better. Also, "prefix" carries more information than "partial". Differential Revision: https://phab.mercurial-scm.org/D3309
author Martin von Zweigbergk <martinvonz@google.com>
date Fri, 13 Apr 2018 22:46:37 -0700
parents c4131138eadb
children e5d87c69bbcb
line wrap: on
line diff
--- a/hgext/histedit.py	Fri Apr 13 09:48:22 2018 -0700
+++ b/hgext/histedit.py	Fri Apr 13 22:46:37 2018 -0700
@@ -443,7 +443,7 @@
         """ Verifies semantic correctness of the rule"""
         repo = self.repo
         ha = node.hex(self.node)
-        self.node = scmutil.resolvepartialhexnodeid(repo, ha)
+        self.node = scmutil.resolvehexnodeidprefix(repo, ha)
         if self.node is None:
             raise error.ParseError(_('unknown changeset %s listed') % ha[:12])
         self._verifynodeconstraints(prev, expected, seen)