diff setup.py @ 9142:63cfacb7917e

merge with crew-stable
author Martin Geisler <mg@lazybytes.net>
date Wed, 15 Jul 2009 17:44:47 +0200
parents ac0f082faa6c 395b0e132836
children c904e76e3834
line wrap: on
line diff
--- a/setup.py	Tue Jul 14 18:00:37 2009 -0700
+++ b/setup.py	Wed Jul 15 17:44:47 2009 +0200
@@ -248,6 +248,8 @@
 datafiles = []
 for root in ('templates', 'i18n'):
     for dir, dirs, files in os.walk(root):
+        dirs[:] = [x for x in dirs if not x.startswith('.')]
+        files = [x for x in files if not x.startswith('.')]
         datafiles.append((os.path.join('mercurial', dir),
                           [os.path.join(dir, file_) for file_ in files]))