diff setup.py @ 48842:649ff7f86f96

rust: enable Python 3 support unconditionally Note: `cpython/python3-sys` is a default feature. Differential Revision: https://phab.mercurial-scm.org/D12316
author Simon Sapin <simon.sapin@octobus.net>
date Thu, 03 Mar 2022 07:53:11 +0100
parents cd3e25adcf84
children 656196c1d442
line wrap: on
line diff
--- a/setup.py	Thu Mar 03 09:45:21 2022 +0900
+++ b/setup.py	Thu Mar 03 07:53:11 2022 +0100
@@ -1380,15 +1380,9 @@
 
         cargocmd = ['cargo', 'rustc', '--release']
 
-        feature_flags = ['python3']
-
-        cargocmd.append('--no-default-features')
-
         rust_features = env.get("HG_RUST_FEATURES")
         if rust_features:
-            feature_flags.append(rust_features)
-
-        cargocmd.extend(('--features', " ".join(feature_flags)))
+            cargocmd.extend(('--features', rust_features))
 
         cargocmd.append('--')
         if sys.platform == 'darwin':