diff rust/rhg/Cargo.toml @ 46601:755c31a1caf9

rhg: Add support for the blackbox extension Only `command` and `commandfinish` events are logged. The `dirty`, `logsource`, `track` and `ignore` configuration items are not supported yet. To indicate commands executed without Python, a `(rust) ` prefix is added in corresponding log messages. Differential Revision: https://phab.mercurial-scm.org/D10012
author Simon Sapin <simon.sapin@octobus.net>
date Tue, 16 Feb 2021 13:08:37 +0100
parents eace48b4a786
children 6cd9f53aaed8
line wrap: on
line diff
--- a/rust/rhg/Cargo.toml	Wed Feb 17 13:00:25 2021 +0100
+++ b/rust/rhg/Cargo.toml	Tue Feb 16 13:08:37 2021 +0100
@@ -9,9 +9,11 @@
 
 [dependencies]
 hg-core = { path = "../hg-core"}
+chrono = "0.4.19"
 clap = "2.33.1"
 derive_more = "0.99"
 log = "0.4.11"
 micro-timer = "0.3.1"
 env_logger = "0.7.1"
 format-bytes = "0.2.0"
+users = "0.11.0"