diff setup.py @ 42451:810f66b468cd

rust: module policy with importrust We introduce two rust+c module policies and a new `policy.importrust()` that makes use of them. This simple approach provides runtime switching of implementations, which is crucial for the performance measurements such as those Octobus does with ASV. It can also be useful for bug analysis. It also has the advantage of making conditionals in Rust callers more uniform, in particular abstracting over specifics like `demandimport` At this point, the build stays unchanged, with the rust-cpython based `rustext` module being built if HGWITHRUSTEXT=cpython. More transparency for the callers, i.e., just using `policy.importmod` would be a much longer term and riskier effort for the following reasons: 1. It would require to define common module boundaries for the three or four cases (pure, c, rust+ext, cffi) and that is premature with the Rust extension currently under heavy development in areas that are outside the scope of the C extensions. 2. It would imply internal API changes that are not currently wished, as the case of ancestors demonstrates. 3. The lack of data or property-like attributes (tp_member and tp_getset) in current `rust-cpython` makes it impossible to achieve direct transparent replacement of pure Python classes by Rust extension code, meaning that the caller sometimes has to be able to make adjustments or provide additional wrapping.
author Georges Racinet <georges.racinet@octobus.net>
date Wed, 29 May 2019 13:27:56 +0200
parents cd1bede340b0
children 94167e701e12
line wrap: on
line diff
--- a/setup.py	Thu Jun 13 23:28:31 2019 +0300
+++ b/setup.py	Wed May 29 13:27:56 2019 +0200
@@ -556,10 +556,17 @@
         if self.distribution.pure:
             modulepolicy = 'py'
         elif self.build_lib == '.':
-            # in-place build should run without rebuilding C extensions
-            modulepolicy = 'allow'
+            # in-place build should run without rebuilding C
+            # and Rust extensions
+            if hgrustext == 'cpython':
+                modulepolicy = 'rust+c-allow'
+            else:
+                modulepolicy = 'allow'
         else:
-            modulepolicy = 'c'
+            if hgrustext == 'cpython':
+                modulepolicy = 'rust+c'
+            else:
+                modulepolicy = 'c'
 
         content = b''.join([
             b'# this file is autogenerated by setup.py\n',