diff rust/hg-cpython/Cargo.toml @ 44540:82f51ab7a2dd

rust: add logging utils This change adds the `log` crate, the community-approved logging facade backed by Rust core developers as well as the logging-consumer crate `simple_logger` to build a foundation for logging from Rust. Using this setup allows us to choose how to log depending on the way `hg-core` is used: if it's within the context of `hg-cpython`, we might not want to use it the same way as with a direct cli for example. Differential Revision: https://phab.mercurial-scm.org/D8252
author Raphaël Gomès <rgomes@octobus.net>
date Fri, 06 Mar 2020 18:08:13 +0100
parents d8d4fa9a7f18
children 245aec57d76a
line wrap: on
line diff
--- a/rust/hg-cpython/Cargo.toml	Fri Mar 06 17:51:24 2020 +0100
+++ b/rust/hg-cpython/Cargo.toml	Fri Mar 06 18:08:13 2020 +0100
@@ -24,6 +24,7 @@
 [dependencies]
 hg-core = { path = "../hg-core"}
 libc = '*'
+simple_logger = "1.6.0"
 
 [dependencies.cpython]
 version = "0.4"