diff setup.py @ 7008:8fee8ff13d37

use Exception(args)-style raising consistently (py3k compatibility)
author Peter Ruibal <peter.ruibal@intel.com>
date Mon, 08 Sep 2008 13:07:00 +0200
parents 359e93ceee3a
children 2c1f18b88b6a
line wrap: on
line diff
--- a/setup.py	Mon Sep 08 12:55:46 2008 +0200
+++ b/setup.py	Mon Sep 08 13:07:00 2008 +0200
@@ -7,7 +7,7 @@
 
 import sys
 if not hasattr(sys, 'version_info') or sys.version_info < (2, 3, 0, 'final'):
-    raise SystemExit, "Mercurial requires python 2.3 or later."
+    raise SystemExit("Mercurial requires python 2.3 or later.")
 
 import os
 import shutil