diff setup.py @ 15527:9926aab3d0b5

setup: fix py2exe generation broken by c3a6ec304055 (issue3116) Py2exe is patching default distutils Distribution class. This patch ensures that the right one is taken when calling hgdist class.
author Pascal Quantin <pascal.quantin@gmail.com>
date Sun, 20 Nov 2011 19:14:36 +0100
parents f9da84a950d0
children 82ce91a9fd94
line wrap: on
line diff
--- a/setup.py	Fri Nov 18 12:01:04 2011 +0100
+++ b/setup.py	Sun Nov 20 19:14:36 2011 +0100
@@ -121,6 +121,8 @@
 try:
     import py2exe
     py2exeloaded = True
+    # import py2exe's patched Distribution class
+    from distutils.core import Distribution
 except ImportError:
     py2exeloaded = False