diff setup.py @ 40859:aa76be85029b

revlog: export symbol of indexType The idea is to wrap the index object with rust-cpython. I haven't tried it, but it should be doable. We'll probably need a better interface than raw function pointers to do more in Rust.
author Yuya Nishihara <yuya@tcha.org>
date Sun, 02 Dec 2018 21:37:42 +0900
parents 67d20f62fd19
children 1eaf62a67c1a
line wrap: on
line diff
--- a/setup.py	Sun Dec 02 21:33:43 2018 +0900
+++ b/setup.py	Sun Dec 02 21:37:42 2018 +0900
@@ -968,6 +968,7 @@
                   'hg-direct-ffi',
                   include_dirs=common_include_dirs,
                   depends=common_depends + ['mercurial/cext/charencode.h',
+                                            'mercurial/cext/revlog.h',
                                             'rust/hg-core/src/ancestors.rs',
                                             'rust/hg-core/src/lib.rs']),
     Extension('mercurial.cext.osutil', ['mercurial/cext/osutil.c'],