diff setup.py @ 51631:bf1d26bd5b6a

obsolete: quote the feature name This makes it at least somewhat clearer that hg is talking about some specific feature and not just outdated code.
author Joerg Sonnenberger <joerg@bec.de>
date Mon, 10 Jun 2024 13:45:57 +0200
parents ee132657647d
children 45ba8416afc4 493034cc3265
line wrap: on
line diff
--- a/setup.py	Mon Jun 10 12:12:56 2024 +0200
+++ b/setup.py	Mon Jun 10 13:45:57 2024 +0200
@@ -252,7 +252,10 @@
         if (
             not e.startswith(b'not trusting file')
             and not e.startswith(b'warning: Not importing')
-            and not e.startswith(b'obsolete feature not enabled')
+            and not (
+                e.startswith(b'obsolete feature not enabled')
+                or e.startswith(b'"obsolete" feature not enabled')
+            )
             and not e.startswith(b'*** failed to import extension')
             and not e.startswith(b'devel-warn:')
             and not (