diff setup.py @ 25073:c1a9e31bec0f

setup: move osutil_ldflags logic to before extmodules definition
author Adrian Buehlmann <adrian@cadifra.com>
date Thu, 14 May 2015 11:04:35 +0200
parents 637a15a8a4c1
children 0021ad4c2309
line wrap: on
line diff
--- a/setup.py	Thu May 14 11:04:31 2015 +0200
+++ b/setup.py	Thu May 14 11:04:35 2015 +0200
@@ -484,6 +484,11 @@
 
 common_depends = ['mercurial/util.h']
 
+osutil_ldflags = []
+
+if sys.platform == 'darwin':
+    osutil_ldflags += ['-framework', 'ApplicationServices']
+
 extmodules = [
     Extension('mercurial.base85', ['mercurial/base85.c'],
               depends=common_depends),
@@ -500,11 +505,6 @@
               depends=common_depends),
     ]
 
-osutil_ldflags = []
-
-if sys.platform == 'darwin':
-    osutil_ldflags += ['-framework', 'ApplicationServices']
-
 extmodules.append(Extension('mercurial.osutil', ['mercurial/osutil.c'],
                             extra_link_args=osutil_ldflags,
                             depends=common_depends))