diff setup.py @ 30698:c3db3bb4699f

setup: pass named argument to setup_zstd The next release from upstream adds another named argument to this function. Specify arguments by name so there is no ambiguity about which argument is being passed.
author Gregory Szorc <gregory.szorc@gmail.com>
date Wed, 04 Jan 2017 19:17:44 -0800
parents 0df215fba6cf
children 561a019c0268
line wrap: on
line diff
--- a/setup.py	Wed Jan 04 14:52:59 2017 -0500
+++ b/setup.py	Wed Jan 04 19:17:44 2017 -0800
@@ -615,7 +615,7 @@
 
 sys.path.insert(0, 'contrib/python-zstandard')
 import setup_zstd
-extmodules.append(setup_zstd.get_c_extension('mercurial.zstd'))
+extmodules.append(setup_zstd.get_c_extension(name='mercurial.zstd'))
 
 try:
     from distutils import cygwinccompiler