diff setup.py @ 38002:cd4959c33d1a

setup: reformat options argument This makes things a bit more easier to manage IMO. Differential Revision: https://phab.mercurial-scm.org/D3540
author Gregory Szorc <gregory.szorc@gmail.com>
date Sat, 12 May 2018 12:12:12 -0700
parents cfb32979abcd
children e5d2248dcc39
line wrap: on
line diff
--- a/setup.py	Sat May 12 10:53:53 2018 -0700
+++ b/setup.py	Sat May 12 12:12:12 2018 -0700
@@ -1066,16 +1066,24 @@
       package_data=packagedata,
       cmdclass=cmdclass,
       distclass=hgdist,
-      options={'py2exe': {'packages': ['hgdemandimport', 'hgext', 'email',
-                                       # implicitly imported per module policy
-                                       # (cffi wouldn't be used as a frozen exe)
-                                       'mercurial.cext',
-                                       #'mercurial.cffi',
-                                       'mercurial.pure']},
-               'bdist_mpkg': {'zipdist': False,
-                              'license': 'COPYING',
-                              'readme': 'contrib/macosx/Readme.html',
-                              'welcome': 'contrib/macosx/Welcome.html',
-                              },
-               },
+      options={
+          'py2exe': {
+              'packages': [
+                  'hgdemandimport',
+                  'hgext',
+                  'email',
+                  # implicitly imported per module policy
+                  # (cffi wouldn't be used as a frozen exe)
+                  'mercurial.cext',
+                  #'mercurial.cffi',
+                  'mercurial.pure',
+              ],
+          },
+          'bdist_mpkg': {
+              'zipdist': False,
+              'license': 'COPYING',
+              'readme': 'contrib/macosx/Readme.html',
+              'welcome': 'contrib/macosx/Welcome.html',
+          },
+      },
       **extra)