diff rust/hg-core/Cargo.toml @ 42302:d1786c1d34fa

rust-dirstate: add rust implementation of `parse_dirstate` and `pack_dirstate` Working towards the goal of having a complete Rust implementation of `hg status`, these two utils are a first step of many to be taken to improve performance and code maintainability. Two dependencies have been added: `memchr` and `byteorder`. Both of them have been written by reputable community members and are very mature crates. The Rust code will often need to use their byte-oriented functions. A few unit tests have been added and may help future development and debugging. In a future patch that uses `parse_dirstate` to stat the working tree in parallel - which neither the Python nor the C implementations do - actual performance improvements will be seen for larger repositories. Differential Revision: https://phab.mercurial-scm.org/D6348
author Raphaël Gomès <rgomes@octobus.net>
date Mon, 06 May 2019 22:48:09 +0200
parents ee7b7bd432a1
children e8f3740cc067
line wrap: on
line diff
--- a/rust/hg-core/Cargo.toml	Tue May 14 22:56:58 2019 -0700
+++ b/rust/hg-core/Cargo.toml	Mon May 06 22:48:09 2019 +0200
@@ -10,3 +10,7 @@
 [dev-dependencies]
 rand = "*"
 rand_pcg = "*"
+
+[dependencies]
+memchr = "2.2.0"
+byteorder = "1.3.1"
\ No newline at end of file