diff setup.py @ 14324:d3a49a52f117

Hardcoding ARCHFLAGS breaks the build against fink's python Fink's python is either i386 or amd64, but not universal. Setting ARCHFLAGS to the empty string produces a successful build against both OS X python and fink python. The modules will no longer be universal -- if that is an issue, we can change the test to extract ARCHFLAGS from distutils.sysconfig and remove ppc if necessary.
author Brendan Cully <brendan@kublai.com>
date Sat, 14 May 2011 22:07:58 -0700
parents bb7e3b3e6e11
children 3818c67a501e
line wrap: on
line diff
--- a/setup.py	Sat May 14 00:30:32 2011 +0200
+++ b/setup.py	Sat May 14 22:07:58 2011 -0700
@@ -386,7 +386,7 @@
     # Also parse only first digit, because 3.2.1 can't be parsed nicely
     if (version.startswith('Xcode') and
         StrictVersion(version.split()[1]) >= StrictVersion('4.0')):
-        os.environ['ARCHFLAGS'] = '-arch i386 -arch x86_64'
+        os.environ['ARCHFLAGS'] = ''
 
 setup(name='mercurial',
       version=setupversion,