diff setup.py @ 41953:d6e3c16d48ab

packaging: don't bundle DLLs in py2exe library.zip for x86 builds I had ported the x86/x64 behavior difference from the Inno Setup installer files. Why things were this way, I'm not sure. The WiX configuration files are expecting to have standalone DLL files for both configurations. And the 32-bit WiX installers were broken due to missing DLLs. Let's standardize on standalone DLL files on all configurations for consistency. I /think/ this will be faster, as I /think/ py2exe binaries would have to extract the DLL to a temporary file in order to load it. But I'm not 100% sure about that. Differential Revision: https://phab.mercurial-scm.org/D6135
author Gregory Szorc <gregory.szorc@gmail.com>
date Thu, 14 Mar 2019 13:27:37 -0700
parents 5d9fdc9b0178
children e5ac701e5b7c
line wrap: on
line diff
--- a/setup.py	Thu Mar 14 18:14:33 2019 -0700
+++ b/setup.py	Thu Mar 14 13:27:37 2019 -0700
@@ -1364,6 +1364,7 @@
       distclass=hgdist,
       options={
           'py2exe': {
+              'bundle_files': 3,
               'dll_excludes': py2exedllexcludes,
               'excludes': py2exeexcludes,
               'packages': py2exepackages,