diff rust/hg-cpython/Cargo.toml @ 44305:d8d4fa9a7f18

rust-re2: add wrapper for calling Re2 from Rust This assumes that Re2 is installed following Google's guide. I am not sure how we want to integrate it in the project, but I think a follow-up patch would be more appropriate for such work. As it stands, *not* having Re2 installed results in a compilation error, which is a problem as it breaks install compatibility. Hence, this is gated behind a non-default `with-re2` compilation feature. Differential Revision: https://phab.mercurial-scm.org/D7910
author Raphaël Gomès <rgomes@octobus.net>
date Thu, 16 Jan 2020 13:34:04 +0100
parents 25ed4d8e707f
children 82f51ab7a2dd
line wrap: on
line diff
--- a/rust/hg-cpython/Cargo.toml	Thu Jan 16 11:27:12 2020 +0100
+++ b/rust/hg-cpython/Cargo.toml	Thu Jan 16 13:34:04 2020 +0100
@@ -10,6 +10,7 @@
 
 [features]
 default = ["python27"]
+with-re2 = ["hg-core/with-re2"]
 
 # Features to build an extension module:
 python27 = ["cpython/python27-sys", "cpython/extension-module-2-7"]
@@ -21,7 +22,7 @@
 python3-bin = ["cpython/python3-sys"]
 
 [dependencies]
-hg-core = { path = "../hg-core" }
+hg-core = { path = "../hg-core"}
 libc = '*'
 
 [dependencies.cpython]