diff setup.py @ 44115:e1b8b4e4f496

rust: add a README In particular to explain how to build any of the rust. It's neither obvious, nor easy to find out, nor easy to determine if you did it right without some documentation. Differential Revision: https://phab.mercurial-scm.org/D7952
author Valentin Gatien-Baron <valentin.gatienbaron@gmail.com>
date Mon, 20 Jan 2020 18:28:46 -0500
parents 4e05272dd681
children 0ab651b5f77c a7f8160cc4e4
line wrap: on
line diff
--- a/setup.py	Mon Jan 20 17:44:03 2020 -0500
+++ b/setup.py	Mon Jan 20 18:28:46 2020 -0500
@@ -1382,9 +1382,9 @@
 class RustEnhancedExtension(RustExtension):
     """A C Extension, conditionally enhanced with Rust code.
 
-    If the HGRUSTEXT environment variable is set to something else
-    than 'cpython', the Rust sources get compiled and linked within the
-    C target shared library object.
+    If the HGWITHRUSTEXT environment variable is set to something else
+    than 'cpython', the Rust sources get compiled and linked within
+    the C target shared library object.
     """
 
     def __init__(self, mpath, sources, rustlibname, subcrate, **kw):