diff setup.py @ 33757:e9996bd7203f

cext: split character encoding functions to new compilation unit This extracts charencode.c from parsers.c, which seems big enough for me to hesitate to add new JSON functions. Still charencode.o is linked to parsers.so to avoid duplication of binary codes.
author Yuya Nishihara <yuya@tcha.org>
date Mon, 31 Jul 2017 22:28:27 +0900
parents 47829b89c8c6
children 0f4ac3b6dee4
line wrap: on
line diff
--- a/setup.py	Mon Jul 31 22:12:24 2017 +0900
+++ b/setup.py	Mon Jul 31 22:28:27 2017 +0900
@@ -760,7 +760,8 @@
                                         'mercurial/cext/mpatch.c'],
               include_dirs=common_include_dirs,
               depends=common_depends),
-    Extension('mercurial.cext.parsers', ['mercurial/cext/dirs.c',
+    Extension('mercurial.cext.parsers', ['mercurial/cext/charencode.c',
+                                         'mercurial/cext/dirs.c',
                                          'mercurial/cext/manifest.c',
                                          'mercurial/cext/parsers.c',
                                          'mercurial/cext/pathencode.c',