diff rust/hg-core/Cargo.toml @ 48953:ec8d9b5a5e7c

rust-hg-core: upgrade dependencies This upgrades all dependencies to their latest version, except `clap` and `zstd` whose latest versions do not support our minimum supported Rust version 1.48.0. Same as for `rhg`, it contains security fix for `regex` which does not affect us too much, but doesn't hurt, and the rest of the upgrades are there simply to keep up. Differential Revision: https://phab.mercurial-scm.org/D12358
author Raphaël Gomès <rgomes@octobus.net>
date Wed, 09 Mar 2022 11:22:22 +0100
parents 11c0411bf4e2
children 12adf8c695ed
line wrap: on
line diff
--- a/rust/hg-core/Cargo.toml	Wed Mar 09 11:17:09 2022 +0100
+++ b/rust/hg-core/Cargo.toml	Wed Mar 09 11:22:22 2022 +0100
@@ -9,40 +9,40 @@
 name = "hg"
 
 [dependencies]
-bitflags = "1.2"
-bytes-cast = "0.2"
-byteorder = "1.3.4"
-derive_more = "0.99"
-hashbrown = {version = "0.9.1", features = ["rayon"]}
-home = "0.5"
-im-rc = "15.0.*"
-itertools = "0.9"
+bitflags = "1.3.2"
+bytes-cast = "0.2.0"
+byteorder = "1.4.3"
+derive_more = "0.99.17"
+hashbrown = { version = "0.9.1", features = ["rayon"] }
+home = "0.5.3"
+im-rc = "15.0.0"
+itertools = "0.10.3"
 lazy_static = "1.4.0"
-libc = "0.2"
-rand = "0.8.4"
+libc = "0.2.119"
+rand = "0.8.5"
 rand_pcg = "0.3.1"
-rand_distr = "0.4.2"
-rayon = "1.3.0"
-regex = "1.3.9"
-sha-1 = "0.9.6"
-twox-hash = "1.5.0"
+rand_distr = "0.4.3"
+rayon = "1.5.1"
+regex = "1.5.5"
+sha-1 = "0.10.0"
+twox-hash = "1.6.2"
 same-file = "1.0.6"
 stable_deref_trait = "1.2.0"
-tempfile = "3.1.0"
-crossbeam-channel = "0.4"
-micro-timer = "0.3.0"
-log = "0.4.8"
-memmap2 = {version = "0.4", features = ["stable_deref_trait"]}
+tempfile = "3.3.0"
+crossbeam-channel = "0.5.2"
+micro-timer = "0.4.0"
+log = "0.4.14"
+memmap2 = { version = "0.5.3", features = ["stable_deref_trait"] }
 zstd = "0.5.3"
 format-bytes = "0.3.0"
 
 # We don't use the `miniz-oxide` backend to not change rhg benchmarks and until
 # we have a clearer view of which backend is the fastest.
 [dependencies.flate2]
-version = "1.0.16"
+version = "1.0.22"
 features = ["zlib"]
 default-features = false
 
 [dev-dependencies]
-clap = "*"
-pretty_assertions = "0.6.1"
+clap = "2.34.0"
+pretty_assertions = "1.1.0"