diff setup.py @ 41851:ed35057421ae

setup: include additional packages in py2exe distribution I'm attempting to reproduce the Inno installers on my local machine. As part of auditing differences between installer output, I noticed that the existing Inno installers include various 3rd party packages. There is no mention of this in the build instructions nor on the wiki. This must be something that is done by the installer producer. This commit teaches setup.py to include these 3rd party packages in py2exe's library. After this change, I am able to produce Inno installers that have a nearly identical set of Python modules. It's worth noting that pywin32 is included even though it probably shouldn't be. But including it is necessary in order to achieve parity with existing Inno installers. Differential Revision: https://phab.mercurial-scm.org/D6064
author Gregory Szorc <gregory.szorc@gmail.com>
date Sun, 03 Mar 2019 15:46:26 -0800
parents d80d48928eb1
children db3098d02a6d
line wrap: on
line diff
--- a/setup.py	Sun Mar 03 10:31:23 2019 -0800
+++ b/setup.py	Sun Mar 03 15:46:26 2019 -0800
@@ -1240,8 +1240,20 @@
 
 extra = {}
 
+py2exepackages = [
+    'hgdemandimport',
+    'hgext',
+    'email',
+    # implicitly imported per module policy
+    # (cffi wouldn't be used as a frozen exe)
+    'mercurial.cext',
+    #'mercurial.cffi',
+    'mercurial.pure',
+]
+
 if issetuptools:
     extra['python_requires'] = supportedpy
+
 if py2exeloaded:
     extra['console'] = [
         {'script':'hg',
@@ -1252,6 +1264,34 @@
     # put dlls in sub directory so that they won't pollute PATH
     extra['zipfile'] = 'lib/library.zip'
 
+    try:
+        import dulwich
+        dulwich.__version__
+        py2exepackages.append('dulwich')
+    except ImportError:
+        pass
+
+    try:
+        import keyring
+        keyring.util
+        py2exepackages.append('keyring')
+    except ImportError:
+        pass
+
+    try:
+        import pygments
+        pygments.__version__
+        py2exepackages.append('pygments')
+    except ImportError:
+        pass
+
+    try:
+        import pywintypes
+        pywintypes.TRUE
+        py2exepackages.append('pywintypes')
+    except ImportError:
+        pass
+
 if os.name == 'nt':
     # Windows binary file versions for exe/dll files must have the
     # form W.X.Y.Z, where W,X,Y,Z are numbers in the range 0..65535
@@ -1331,16 +1371,7 @@
       distclass=hgdist,
       options={
           'py2exe': {
-              'packages': [
-                  'hgdemandimport',
-                  'hgext',
-                  'email',
-                  # implicitly imported per module policy
-                  # (cffi wouldn't be used as a frozen exe)
-                  'mercurial.cext',
-                  #'mercurial.cffi',
-                  'mercurial.pure',
-              ],
+              'packages': py2exepackages,
           },
           'bdist_mpkg': {
               'zipdist': False,