diff rust/hg-core/Cargo.toml @ 50763:f8412da86d05

rust-config: add support for default config items Now that configitems.toml exists, we can read from it the default values for all core config items. We will add the devel-warning for use of undeclared config items in a later patch when we're done adding the missing entries for `rhg`.
author Raphaël Gomès <rgomes@octobus.net>
date Thu, 06 Jul 2023 14:32:07 +0200
parents 2cc5de261d76
children c4f1a790bda8
line wrap: on
line diff
--- a/rust/hg-core/Cargo.toml	Mon Jan 23 18:08:11 2023 +0100
+++ b/rust/hg-core/Cargo.toml	Thu Jul 06 14:32:07 2023 +0200
@@ -26,10 +26,12 @@
 rayon = "1.7.0"
 regex = "1.7.0"
 self_cell = "1.0"
+serde = { version = "1.0", features = ["derive"] }
 sha-1 = "0.10.0"
 twox-hash = "1.6.3"
 same-file = "1.0.6"
 tempfile = "3.3.0"
+toml = "0.6"
 thread_local = "1.1.4"
 crossbeam-channel = "0.5.6"
 log = "0.4.17"
@@ -46,5 +48,5 @@
 default-features = false
 
 [dev-dependencies]
-clap = { version = "4.0.24", features = ["derive"] }
+clap = { version = "~4.0", features = ["derive"] }
 pretty_assertions = "1.1.0"