--- a/setup.py Thu Oct 03 23:39:29 2019 -0400
+++ b/setup.py Mon Sep 30 17:26:41 2019 -0700
@@ -490,6 +490,14 @@
return build_ext.initialize_options(self)
+ def finalize_options(self):
+ # Unless overridden by the end user, build extensions in parallel.
+ # Only influences behavior on Python 3.5+.
+ if getattr(self, 'parallel', None) is None:
+ self.parallel = True
+
+ return build_ext.finalize_options(self)
+
def build_extensions(self):
ruststandalones = [e for e in self.extensions
if isinstance(e, RustStandaloneExtension)]