diff setup.py @ 42065:fecbd93a5f08

setup: use raw string for regular expression Otherwise Python 3.8 complains about the backslash. Differential Revision: https://phab.mercurial-scm.org/D6202
author Gregory Szorc <gregory.szorc@gmail.com>
date Thu, 04 Apr 2019 18:01:48 -0700
parents 399ed3e86a49
children 59b1bdf85b1a
line wrap: on
line diff
--- a/setup.py	Thu Apr 04 18:01:02 2019 -0700
+++ b/setup.py	Thu Apr 04 18:01:48 2019 -0700
@@ -796,7 +796,7 @@
 
         # This logic is duplicated in doc/Makefile.
         sources = {f for f in os.listdir('mercurial/help')
-                   if re.search('[0-9]\.txt$', f)}
+                   if re.search(r'[0-9]\.txt$', f)}
 
         # common.txt is a one-off.
         gentxt('common')