patchbomb: make it easy for the user to decline sending an intro message.
- prompt(): respect interactive mode; clarify logic a bit
- rename introneeded() to introwanted() and give it only one caller
- add 'numbered' arg to makepatch() so it does not need to call
introwanted()
- factor makeintro() out of getpatchmsgs(), so it's easier to skip the
intro message based on the user's behaviour
Unexpected but perfectly reasonable side effect: in non-interactive
mode, we don't show unanswerable "Cc" or "From" prompts anymore, so
remove those from the test expectations.
% tedious monotone keys configuration
% create monotone repository
mtn: adding dir1 to workspace manifest
mtn: adding dir1/subdir1 to workspace manifest
mtn: adding dir1/subdir1/file1 to workspace manifest
mtn: beginning commit on branch 'com.selenic.test'
mtn: committed revision 5ed13ff5582d8d1e319f079b694a37d2b45edfc8
% rename directory
mtn: skipping dir1, already accounted for in workspace
mtn: renaming dir1/subdir1 to dir1/subdir2 in workspace manifest
mtn: beginning commit on branch 'com.selenic.test'
mtn: committed revision 985204142a822b22ee86b509d61f3c5ab6857d2b
% convert
assuming destination repo.mtn-hg
initializing destination repo.mtn-hg repository
scanning source...
sorting...
converting...
1 initialize
0 rename
1 files updated, 0 files merged, 0 files removed, 0 files unresolved
% manifest
dir1/subdir2/file1