Mercurial > hg
view tests/test-update-renames.t @ 15164:7bddec632821
patchbomb: make it easy for the user to decline sending an intro message.
- prompt(): respect interactive mode; clarify logic a bit
- rename introneeded() to introwanted() and give it only one caller
- add 'numbered' arg to makepatch() so it does not need to call
introwanted()
- factor makeintro() out of getpatchmsgs(), so it's easier to skip the
intro message based on the user's behaviour
Unexpected but perfectly reasonable side effect: in non-interactive
mode, we don't show unanswerable "Cc" or "From" prompts anymore, so
remove those from the test expectations.
author | Greg Ward <greg@gerg.ca> |
---|---|
date | Tue, 27 Sep 2011 22:38:47 -0400 |
parents | b63f6422d2a7 |
children | 2371f4aea665 |
line wrap: on
line source
Test update logic when there are renames Update with local changes across a file rename $ hg init $ echo a > a $ hg add a $ hg ci -m a $ hg mv a b $ hg ci -m rename $ echo b > b $ hg ci -m change $ hg up -q 0 $ echo c > a $ hg up merging a and b to b warning: conflicts during merge. merging b failed! 0 files updated, 0 files merged, 0 files removed, 1 files unresolved use 'hg resolve' to retry unresolved file merges [1] $ cd ..