Mercurial > hg
view .jshintrc @ 40847:b34b1b865ef9
remotefilelog: avoid temporarily using "count" variable as synonym for "total"
The "count" variable is generally used for updating progress, but
early in fileserverclient.request(), its used to mean the total
count. We already have another "total" variable for that, so it seems
much clearer to use that.
Differential Revision: https://phab.mercurial-scm.org/D5382
author | Martin von Zweigbergk <martinvonz@google.com> |
---|---|
date | Tue, 04 Dec 2018 21:58:46 -0800 |
parents | bdd2e18b54c5 |
children |
line wrap: on
line source
{ // Enforcing "eqeqeq" : true, // true: Require triple equals (===) for comparison "forin" : true, // true: Require filtering for..in loops with obj.hasOwnProperty() "freeze" : true, // true: prohibits overwriting prototypes of native objects such as Array, Date etc. "nonbsp" : true, // true: Prohibit "non-breaking whitespace" characters. "undef" : true, // true: Require all non-global variables to be declared (prevents global leaks) // Environments "browser" : true // Web Browser (window, document, etc) }