tests/crashgetbundler.py
author Martin von Zweigbergk <martinvonz@google.com>
Thu, 15 Jun 2017 13:47:54 -0700
changeset 32870 b441296f8e9c
parent 30914 f3807a135e43
child 43076 2372284d9457
permissions -rw-r--r--
changegroup: rename "dh" to the clearer "deltaheads" We have a lot of frequently used abbreviations, but this is not one of them.

from __future__ import absolute_import

from mercurial.i18n import _
from mercurial import (
        changegroup,
        error,
        extensions
    )

def abort(orig, *args, **kwargs):
    raise error.Abort(_('this is an exercise'))

def uisetup(ui):
    extensions.wrapfunction(changegroup, 'getbundler', abort)