Mercurial > hg
view contrib/packaging/debian/rules @ 39989:c9026e9297e3
identify: only query remote bookmarks if needed
Instead of all the time when operating on a remote repo. This
perf regression was introduced in 15a79ac823e8, in 4.3.
This datahint method returns nothing for -Tjson, -Tpickle, -Tdebug
--config ui.formatdebug=true and --config ui.formatjson, so the
bookmarks won't show up. I don't know what these formatters are for.
plainformatter and templateformatter work properly, and the few other
uses of datahint should have the same kind of problem.
There is further weirdness where "--template '{node}'" is not enough
to avoid querying the bookmarks, you also need to pass --id or -q.
Differential Revision: https://phab.mercurial-scm.org/D4819
author | Valentin Gatien-Baron <vgatien-baron@janestreet.com> |
---|---|
date | Mon, 01 Oct 2018 09:58:42 -0400 |
parents | e51c91c14a07 |
children | 7574ccd87200 |
line wrap: on
line source
#!/usr/bin/make -f # Uncomment this to turn on verbose mode. # export DH_VERBOSE=1 CPUS=$(shell cat /proc/cpuinfo | grep -E ^processor | wc -l) %: dh $@ --with python2 override_dh_auto_test: http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)" override_dh_python2: dh_python2 find debian/mercurial/usr/share -type d -empty -delete override_dh_install: python$(PYVERS) setup.py install --root "$(CURDIR)"/debian/mercurial --install-layout=deb # chg make -C contrib/chg \ DESTDIR="$(CURDIR)"/debian/mercurial \ PREFIX=/usr \ clean install # remove arch-independent python stuff find "$(CURDIR)"/debian/mercurial/usr/lib \ ! -name '*.so' ! -type d -delete , \ -type d -empty -delete python$(PYVERS) setup.py install --root "$(CURDIR)/debian/mercurial-common" --install-layout=deb make install-doc PREFIX="$(CURDIR)"/debian/mercurial-common/usr # remove arch-dependent python stuff find "$(CURDIR)"/debian/mercurial-common/usr/lib \ -name '*.so' ! -type d -delete , \ -type d -empty -delete cp contrib/hg-ssh "$(CURDIR)"/debian/mercurial-common/usr/bin mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial cp contrib/hgk "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial mkdir -p "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/ cp contrib/packaging/debian/*.rc "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/ # completions mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions cp contrib/bash_completion "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions/hg mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions cp contrib/zsh_completion "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions/_hg rm "$(CURDIR)"/debian/mercurial-common/usr/bin/hg