Mercurial > hg
view contrib/debian/rules @ 35998:dce43aaaf209
lfs: allow a pointer to be extracted from a context that removes the file
This is needed to let 'set:lfs()' and '{lfs_files}' work normally on removed
files.
Yuya suggested returning a null pointer for removed files, instead of the
pointer from the parent. The first attempt at this was to return None for a non
LFS file, and a (pointer, ctx) tuple to hold the pointer and context (or parent
pointer and context for a removed file). But this complicated the callers, even
the ones that didn't care about removed files.
Instead, let's use {} to represent a removed pointer. This has the added
convenience of being a useful representation in the template language, and only
affects the callers that care about removed files (and only slightly). Since
pointers are explicitly serialized with a call to a member function, there is no
danger of writing these to disk.
author | Matt Harbison <matt_harbison@yahoo.com> |
---|---|
date | Sat, 27 Jan 2018 18:56:24 -0500 |
parents | f1c2552c2de7 |
children |
line wrap: on
line source
#!/usr/bin/make -f # Uncomment this to turn on verbose mode. # export DH_VERBOSE=1 CPUS=$(shell cat /proc/cpuinfo | grep -E ^processor | wc -l) %: dh $@ --with python2 override_dh_auto_test: http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)" override_dh_python2: dh_python2 find debian/mercurial/usr/share -type d -empty -delete override_dh_install: python$(PYVERS) setup.py install --root "$(CURDIR)"/debian/mercurial --install-layout=deb # chg make -C contrib/chg \ DESTDIR="$(CURDIR)"/debian/mercurial \ PREFIX=/usr \ clean install # remove arch-independent python stuff find "$(CURDIR)"/debian/mercurial/usr/lib \ ! -name '*.so' ! -type d -delete , \ -type d -empty -delete python$(PYVERS) setup.py install --root "$(CURDIR)/debian/mercurial-common" --install-layout=deb make install-doc PREFIX="$(CURDIR)"/debian/mercurial-common/usr # remove arch-dependent python stuff find "$(CURDIR)"/debian/mercurial-common/usr/lib \ -name '*.so' ! -type d -delete , \ -type d -empty -delete cp contrib/hg-ssh "$(CURDIR)"/debian/mercurial-common/usr/bin mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial cp contrib/hgk "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial mkdir -p "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/ cp contrib/debian/*.rc "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/ # completions mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions cp contrib/bash_completion "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions/hg mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions cp contrib/zsh_completion "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions/_hg rm "$(CURDIR)"/debian/mercurial-common/usr/bin/hg