Mercurial > hg
view contrib/debian/rules @ 30798:f50c0db50025
util: compression APIs to support revlog decompression
Previously, compression engines had APIs for performing revlog
compression but no mechanism to perform revlog decompression. This
patch changes that.
Revlog decompression is slightly more complicated than compression
because in the compression case there is (currently) only a single
engine that can be used at a time. However for decompression, a
revlog could contain chunks from multiple compression engines. This
means decompression needs to map to multiple engines and
decompressors. This functionality is outside the scope of this patch.
But it drives the decision for engines to declare a byte header
sequence that identifies revlog data as belonging to an engine and
an API for obtaining an engine from a revlog header.
author | Gregory Szorc <gregory.szorc@gmail.com> |
---|---|
date | Mon, 02 Jan 2017 13:27:20 -0800 |
parents | 0c42b6bb2329 |
children | 9ecc622ca23f |
line wrap: on
line source
#!/usr/bin/make -f # Uncomment this to turn on verbose mode. # export DH_VERBOSE=1 CPUS=$(shell cat /proc/cpuinfo | grep -E ^processor | wc -l) %: dh $@ --with python2 override_dh_auto_test: http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)" override_dh_python2: dh_python2 find debian/mercurial/usr/share -type d -empty -delete override_dh_install: python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial --install-layout=deb # remove arch-independent python stuff find $(CURDIR)/debian/mercurial/usr/lib \ ! -name '*.so' ! -type d -delete , \ -type d -empty -delete python$(PYVERS) setup.py install --root $(CURDIR)/debian/mercurial-common --install-layout=deb make install-doc PREFIX=$(CURDIR)/debian/mercurial-common/usr # remove arch-dependent python stuff find $(CURDIR)/debian/mercurial-common/usr/lib \ -name '*.so' ! -type d -delete , \ -type d -empty -delete cp contrib/hg-ssh $(CURDIR)/debian/mercurial-common/usr/bin mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/mercurial cp contrib/hgk $(CURDIR)/debian/mercurial-common/usr/share/mercurial mkdir -p $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ cp contrib/debian/*.rc $(CURDIR)/debian/mercurial-common/etc/mercurial/hgrc.d/ mkdir -p $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions cp contrib/bash_completion $(CURDIR)/debian/mercurial-common/usr/share/bash-completion/completions/hg rm $(CURDIR)/debian/mercurial-common/usr/bin/hg