Mercurial > hg
view .jshintrc @ 38304:fabfbbf4dee2
templatefilters: rename commonprefix to commondir
Two reasons:
* It makes it clearer that it's not a generic common string
prefix (e.g. commonprefix(["bar", "baz"]) is not "ba", but "")
* If we ever want a filter for generic common string prefix,
then the name is now available for that.
"commondir" does not describe the prefix-ness, however. I'm happy to
rename it "commondirprefix" or "commonprefixdir" if others prefer.
Differential Revision: https://phab.mercurial-scm.org/D3731
author | Martin von Zweigbergk <martinvonz@google.com> |
---|---|
date | Wed, 13 Jun 2018 14:28:39 -0700 |
parents | bdd2e18b54c5 |
children |
line wrap: on
line source
{ // Enforcing "eqeqeq" : true, // true: Require triple equals (===) for comparison "forin" : true, // true: Require filtering for..in loops with obj.hasOwnProperty() "freeze" : true, // true: prohibits overwriting prototypes of native objects such as Array, Date etc. "nonbsp" : true, // true: Prohibit "non-breaking whitespace" characters. "undef" : true, // true: Require all non-global variables to be declared (prevents global leaks) // Environments "browser" : true // Web Browser (window, document, etc) }