phabricator: migrate [phabricator.auth] to [auth]
This resurrects the warning mechanism removed in
20a4543e9a2b. I'm not worried
about the copy/paste of the code for a brief transitional period.
dispatch: unify handling of None returned by a command function
A command function may return None in place of 0 just for convenience, but
dispatch() doesn't need to inherit that property. This patch makes it be
friendly to callers.
dispatch: minor code refactor
This hopefully makes things slightly easier to read.
Differential Revision: https://phab.mercurial-scm.org/D3537
hgweb: convert {comparison} to a mappinggenerator with named template
No bare generator.
hgweb: rename 'context' argument of webutil.compare() to avoid name conflicts
The meaning of 'context' depends on context. Here it is the number of the
context lines in unified diff.
hgweb: convert comparison {lines} to a mappinggenerator with named template
Bare generator can't be restarted.
hgweb: move getblock() closure out of compare()
(Please use 'hg diff -w' to get readable diff from this patch.)
hgweb: convert {diff} to a mappinggenerator with named template
No more bare generator. Fortunately, this one is associated with a single
template, so it can be a mappinggenerator.