Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:47:21 +0200] rev 14594
mq: rename write_list to writelist
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:45:48 +0200] rev 14593
mq: rename series_dirty to seriesdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:44:34 +0200] rev 14592
mq: rename applied_dirty to applieddirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:43:03 +0200] rev 14591
mq: rename guards_dirty to guardsdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:41:58 +0200] rev 14590
mq: rename active_guards to activeguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:40:35 +0200] rev 14589
mq: rename guards_path to guardspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:39:14 +0200] rev 14588
mq: rename status_path to statuspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:38:04 +0200] rev 14587
mq: rename series_path to seriespath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:11:49 +0200] rev 14586
mq: rename series_end to seriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:09:29 +0200] rev 14585
mq: rename full_series_end to fullseriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:07:46 +0200] rev 14584
mq: rename check_reserved_name to checkreservedname
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:06:32 +0200] rev 14583
mq: rename check_localchanges to checklocalchanges
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:05:20 +0200] rev 14582
mq: rename check_substate to checksubstate
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:03:38 +0200] rev 14581
mq: rename check_toppatch to checktoppatch
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:02:14 +0200] rev 14580
mq: rename save_dirty to savedirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:00:56 +0200] rev 14579
mq: rename explain_pushable to explainpushable
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:59:35 +0200] rev 14578
mq: rename set_active to setactive
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:58:16 +0200] rev 14577
mq: rename set_guards to setguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:57:21 +0200] rev 14576
mq: rename check_guard to checkguard
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:55:46 +0200] rev 14575
mq: rename parse_series to parseseries
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:54:25 +0200] rev 14574
mq: rename find_series to findseries
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:40:27 +0200] rev 14573
mq: rename series_guards to seriesguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 11:06:11 +0200] rev 14572
mq: rename full_series to fullseries
Steven Brown <StevenGBrown@gmail.com> [Sat, 11 Jun 2011 21:24:50 +0800] rev 14571
paper, coal: display diffstat on the changeset page
Displayed in a row of the changeset summary table, underneath the list of
files. When the page is loaded, only the diff summary is displayed. The full
diffstat is only displayed when the [+] link is selected.
Steven Brown <StevenGBrown@gmail.com> [Sat, 11 Jun 2011 21:11:43 +0800] rev 14570
web: provide diff summary to the changeset page
This is the same message displayed at the end of the "diff --stat" command.
For example, "9 files changed, 1651 insertions(+), 2 deletions(-)".
The webutil.diffstatgen function allows the diffstat data to be lazily
calculated only once and then re-used.
Matt Mackall <mpm@selenic.com> [Sat, 11 Jun 2011 14:14:53 -0500] rev 14569
tests: fix up date ambiguity in cvs test
Matt Mackall <mpm@selenic.com> [Sat, 11 Jun 2011 14:14:52 -0500] rev 14568
hg: split peer and repo lookup tables
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:40:25 +0200] rev 14567
tests: rename test-git-import.t into test-import-git.t
This is consistent with other test-import* tests.
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:17:25 +0200] rev 14566
patch: generalize the use of patchmeta in applydiff()
- Add patchmeta.copy() and emit copies from iterhunks. Modifying patchmeta
instances in applydiff() makes things simpler.
- Rename selectfile() into makepatchmeta(). It is responsible for creating
patchmeta for regular patches.
- Pass patchmeta objects to patchfile() directly
patchmeta instances were associated with git patches, for regular patches we
had to pass additional variables to tell the patch intent to patchfile().
Instead, we generate patchmeta for regular patches and pass them. This will
also help with patch filtering by matcher objects.
Patrick Mezard <pmezard@gmail.com> [Sat, 11 Jun 2011 14:14:13 +0200] rev 14565
patch: stop updating changed files set in applydiff()
This information is more correctly returned by backends.
The extra updated file removed from test-mq-merge.t output came from changes
from git patches being counted before being really applied in some cases.