Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 17:04:43 +0900] rev 37115
util: mark platform-specific gethgcmd() as private
util.hgcmd() is the public interface for gethgcmd().
Matt Harbison <matt_harbison@yahoo.com> [Sat, 24 Mar 2018 22:10:58 -0400] rev 37114
test-pathconflicts-merge: stop requiring symlink support
The errors from the last time I took a shot at this back in early November have
disappeared, so let's just enable this.
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 17:50:54 -0800] rev 37113
commands: use constants for merge things
We have nice constants now. Let's use them to make the code
easier to reason about.
Differential Revision: https://phab.mercurial-scm.org/D2702
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 18:10:36 -0800] rev 37112
merge: use constants for actions
We finish up establishing named constants in this file with
actions.
I remember scratching my head trying to figure out what this
code was doing as part of addressing a recent security issue with
subrepos. Having the named constants in place definitely makes
things easier to read.
I'm not convinced the new constants have the best names (I'm not
an expert in this code). But they can be changed easily enough.
Also, since these constants are internal only, we might want
to change their values to something more human readable to
facilitate debugging. Or maybe we could employ an enum type
some day...
Differential Revision: https://phab.mercurial-scm.org/D2701
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:21:57 -0500] rev 37111
merge: use constants for merge record state
Named constants are easier to read than short string values.
Differential Revision: https://phab.mercurial-scm.org/D2700
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:15:31 -0500] rev 37110
merge: use constants for merge driver state
Named constants are superior to magic values.
Differential Revision: https://phab.mercurial-scm.org/D2699
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:09:23 -0500] rev 37109
merge: use constants for merge state record types
merge.py is using multiple discrete sets of 1 and 2 letter constants
to define types and behavior. To the uninitiated, the code is very
difficult to reason about. I didn't even realize there were multiple
sets of constants in play initially!
We begin our sanity injection with merge state records. The record
types (which are serialized to disk) are now defined in RECORD_*
constants.
Differential Revision: https://phab.mercurial-scm.org/D2698
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 00:28:40 -0500] rev 37108
histedit: always define update results
Before, we had a branch that could return None for the update stats.
Let's just return an updateresult instance instead.
Differential Revision: https://phab.mercurial-scm.org/D2693
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 00:02:13 -0500] rev 37107
merge: return an attrs class from update() and applyupdates()
Previously, we returned a tuple containing counts. The result of an
update is kind of complex and the use of tuples with nameless fields
made the code a bit harder to read and constrained future expansion
of the return value.
Let's invent an attrs-defined class for representing the result of
an update operation.
We provide __getitem__ and __len__ implementations for backwards
compatibility as a container type to minimize code churn.
In (at least) Python 2, the % operator seems to insist on using
tuples. So we had to update a consumer using the % operator.
.. api::
merge.update() and merge.applyupdates() now return a class
with named attributes instead of a tuple. Switch consumers
to access elements by name instead of by offset.
Differential Revision: https://phab.mercurial-scm.org/D2692
Sangeet Kumar Mishra <mail2sangeetmishra@gmail.com> [Fri, 23 Feb 2018 11:48:58 +0530] rev 37106
histedit: make histedit's commands accept revsets (
issue5746)
Earlier the code was only looking for rulehashes and neglecting
all other revision identifiers, this code intercepts the fromrule function
and calls scmutil.revsingle() on anything that is not a rulehash and then
obtains the rulehash from the changectx object returned, rest of the pipeline
follows as it was
Differential Revision: https://phab.mercurial-scm.org/D2394
Yuya Nishihara <yuya@tcha.org> [Sat, 17 Mar 2018 17:54:33 +0900] rev 37105
formatter: make 'originalnode' a thing in log-like templates
mapping['node'] doesn't work since {node} is computed dynamically in non-web
templates.
Yuya Nishihara <yuya@tcha.org> [Sat, 17 Mar 2018 17:41:07 +0900] rev 37104
formatter: port handling of 'originalnode' to populatemap() hook
This isn't a pure templating business, so let's move out of the templater
module.
Note that this works only in web templates where mapping['node'] is a static
value.
Yuya Nishihara <yuya@tcha.org> [Thu, 15 Mar 2018 21:52:47 +0900] rev 37103
templater: switch 'revcache' based on new mapping items
It was pretty easy to leave a stale 'revcache' when switching 'ctx'.
Let's make it be automatically replaced.
Yuya Nishihara <yuya@tcha.org> [Thu, 15 Mar 2018 21:49:33 +0900] rev 37102
templater: add hook point to populate additional mapping items
The 'revcache' dict will be inserted by this hook.
Matt Harbison <matt_harbison@yahoo.com> [Sat, 24 Mar 2018 01:30:50 -0400] rev 37101
context: skip path conflicts by default when clearing unknown file (
issue5776)
Prior to adding path conflict checking in
989e884d1be9, the test-audit-path.t
tests failed as shown here (but it was globbed away).
989e884d1be9 made it fail
with a message about the destination manifest containing a conflict (though the
no-symlink case wasn't updated). When the path conflict checking was gated
behind an experimental config in
2a774cae3a03^::
2a774cae3a03, the update started
erroneously succeeding here. It turns out that the child of
989e884d1be9 is the
origin of this change when path conflict checking is disabled, as shown by
grafting the experimental config range on top of it.
What's happening here is merge.batchget() is writing the symlink 'back' to wdir
(but as a regular file for the no-symlink case), and then tries to write
'back/test', but calls wctx['back/test'].clearunknown() first. The code that's
gated here was removing the newly written 'back' file, allowing 'back/test' to
succeed. I tried checking for the dir components of 'back/test' in dirstate,
and skipping removal if present. But that didn't work because the dirstate
isn't updated after each file is written out.
This is the last persistent test failure on Windows, so the testbot should start
turning green now. \o/
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 13:02:27 +0900] rev 37100
url: make logginghttphandler compatible with Python 2.7.6
There wasn't a usable hook point in httplib, so we have to replace connect()
to wrap the socket before self._tunnel().
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:24:32 +0900] rev 37099
util: make safehasattr() a pycompat function
So safehasattr() can be imported by utils.* modules. util.safehasattr() still
remains as an alias since it is pretty basic utility available for years.
On current Python 3, the builtin hasattr() should have no problem.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:13:37 +0900] rev 37098
util: drop util.Abort in favor of error.Abort (API)
IIRC, error.Abort exists since Mercurial 1.2, so it should be pretty easy
for extensions authors to update their code.
.. api::
The util.Abort alias has been removed. Use error.Abort.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:09:44 +0900] rev 37097
test-bundle2-exchange: use error.Abort instead of util.Abort
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:08:50 +0900] rev 37096
util: use error.Abort instead of local alias
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 13:30:50 +0900] rev 37095
rcutil: directly call win32.executablepath()
Since it isn't supported on POSIX platform, we don't need to double the
compatibility layers.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 17:19:32 +0900] rev 37094
directaccess: do not abort by 'ff...' hash
Since the 'ff...' hash should never be hidden, we can just ignore it.
Gregory Szorc <gregory.szorc@gmail.com> [Fri, 23 Mar 2018 11:20:13 -0700] rev 37093
hgweb: don't responsd to api requests unless feature is enabled
Per discussion at https://phab.mercurial-scm.org/D2834, new URLs
in hgweb can conflict with subrepos and virtual repos. This may prevent
access to repos in certain paths or having certain names.
Until we have a workaround for this, let's not serve requests for
"api/" URLs unless the feature is enabled.
Differential Revision: https://phab.mercurial-scm.org/D2936
Daniel Ploch <dploch@google.com> [Fri, 23 Mar 2018 11:20:49 -0700] rev 37092
fancyopts: prevent mutation of the default value in customopts
Differential Revision: https://phab.mercurial-scm.org/D2937
Daniel Ploch <dploch@google.com> [Thu, 22 Mar 2018 17:08:25 -0700] rev 37091
fancyopts: fix rendering of customopt defaults in help text
Differential Revision: https://phab.mercurial-scm.org/D2935
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 12 Mar 2018 18:38:26 +0530] rev 37090
remotenames: show remote bookmarks in `hg bookmarks`
This patch adds functionality to show list of remote bookmarks in `hg bookmarks`
command.
There is some indenting problem in the test output as the current bookmark
printing code in core can handle bookmark names of size 25 only gracefully.
The idea is taken from hgremotenames extension which has --remote and --all
flags to show remote bookmarks. However, this patch by defaults support showing
list of remote bookmarks if remotenames extension is enabled and remotebookmarks
are turned on.
Differential Revision: https://phab.mercurial-scm.org/D2808
Pulkit Goyal <7895pulkit@gmail.com> [Sun, 11 Mar 2018 16:17:51 +0530] rev 37089
remotenames: add functionality to hoist remotebookmarks
This patch adds the functionality to hoist remotebookmarks to the top level
namespace. The peer of which bookmarks should be hoisted can be set using
`remotenames.hoistedpeer` config option. Only bookmarks can be hoisted. If a
hoisted name and local bookmark exists of the same name, the local bookmark
takes precedence.
While I was here, I documented the default values of two other remotenames
config options.
Differential Revision: https://phab.mercurial-scm.org/D2807
Kyle Lippincott <spectral@google.com> [Thu, 08 Mar 2018 11:44:03 -0800] rev 37088
copyfile: preserve stat info (mtime, etc.) when doing copies/renames
Differential Revision: https://phab.mercurial-scm.org/D2729
Matt Harbison <matt_harbison@yahoo.com> [Thu, 22 Mar 2018 22:58:31 -0400] rev 37087
merge: add 'isknown=True' to a dirstate.normalize() in _unknowndirschecker
Per the docstring for dirstate.normalize().
Matt Harbison <matt_harbison@yahoo.com> [Thu, 22 Mar 2018 22:56:29 -0400] rev 37086
merge: pconvert paths in _unknowndirschecker before dirstate-normalizing
This fixes the failure in test-pathconflicts-basic.t on Windows. The test was
passing in 'a\b', which was getting normalized to 'A\B', which isn't in
dirstate. (The filesystem path is all lowercase anyway.)
This isn't the only case of calling dirstate.normalize(), but other methods here
(util.finddirs()) seem to assume the input paths are already using '/'. I think
the backslash comes from wvfs.reljoin() (in this case), but could also come from
wvfs.walk(), so this is the only case that needs it.