Tue, 21 Jul 2020 13:41:26 -0700 templater: simplify stylemap() now that templatedir() returns a single path
Martin von Zweigbergk <martinvonz@google.com> [Tue, 21 Jul 2020 13:41:26 -0700] rev 45200
templater: simplify stylemap() now that templatedir() returns a single path Differential Revision: https://phab.mercurial-scm.org/D8787
Tue, 21 Jul 2020 13:11:49 -0700 templater: make templatepaths() return a single path, or None
Martin von Zweigbergk <martinvonz@google.com> [Tue, 21 Jul 2020 13:11:49 -0700] rev 45199
templater: make templatepaths() return a single path, or None The function returns either a singleton list or an empty list, so it makes more sense to return a value or None. The plural in the name also doesn't make sense, but `templatepath()` is already taken, so I renamed it to `templatedir()` instead. Differential Revision: https://phab.mercurial-scm.org/D8786
Tue, 21 Jul 2020 13:05:37 -0700 templater: simplify templatepaths() to avoid iterating a singleton list
Martin von Zweigbergk <martinvonz@google.com> [Tue, 21 Jul 2020 13:05:37 -0700] rev 45198
templater: simplify templatepaths() to avoid iterating a singleton list The function iterates over a hard-coded list of one element since d844e220792a (templater: don't search randomly for templates - trust util.datapath, 2014-09-28). Differential Revision: https://phab.mercurial-scm.org/D8785
Mon, 06 Jul 2020 22:46:49 +0200 commitctx: move a tiny else clause above the very long one
Pierre-Yves David <pierre-yves.david@octobus.net> [Mon, 06 Jul 2020 22:46:49 +0200] rev 45197
commitctx: move a tiny else clause above the very long one This is simple to have all the simple case unfold before the 100+ line one. Otherwise it is hard to relate the `else` to the initial conditionnal. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8708
Mon, 06 Jul 2020 22:37:53 +0200 commitctx: consider removed as touched
Pierre-Yves David <pierre-yves.david@octobus.net> [Mon, 06 Jul 2020 22:37:53 +0200] rev 45196
commitctx: consider removed as touched This achieve the same result with clearer code. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8707
Mon, 06 Jul 2020 22:35:34 +0200 commitctx: rename "changed" to touched
Pierre-Yves David <pierre-yves.david@octobus.net> [Mon, 06 Jul 2020 22:35:34 +0200] rev 45195
commitctx: rename "changed" to touched The variable contains content that are both added and modified. "changed" could be confused with "modified" only, so we pick a less ambiguous naming that will help with more unification. For example, it would make sense to shove the "removed" item in there since this is how the variable is used. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8706
Tue, 07 Jul 2020 11:16:28 +0200 commitctx: more filesremoved assignment closer to removed computation
Pierre-Yves David <pierre-yves.david@octobus.net> [Tue, 07 Jul 2020 11:16:28 +0200] rev 45194
commitctx: more filesremoved assignment closer to removed computation A small change that makes the code flow clearer. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8704
Mon, 06 Jul 2020 20:03:30 +0200 commitctx: compute files added from _filecommit returns
Pierre-Yves David <pierre-yves.david@octobus.net> [Mon, 06 Jul 2020 20:03:30 +0200] rev 45193
commitctx: compute files added from _filecommit returns When possible, lets avoid recomputing the same information again. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8703
Mon, 06 Jul 2020 19:35:53 +0200 commitctx: return "touched" status from _filecommit
Pierre-Yves David <pierre-yves.david@octobus.net> [Mon, 06 Jul 2020 19:35:53 +0200] rev 45192
commitctx: return "touched" status from _filecommit Instead of mutating a list passed in argument, we simply return the information from the `_filecommit` function. This make for a cleaner API and allow for richer information to be returned. That richer information will be used in the next commit to avoid duplicated computation. This is part of a larger refactoring/cleanup of the commitctx code to clarify and augment the logic gathering metadata useful for copy tracing. The current code is a tad too long and entangled to make such update easy. We start with easy and small cleanup. Differential Revision: https://phab.mercurial-scm.org/D8702
Tue, 21 Jul 2020 01:04:19 +0200 relnotes: add release notes for relevant changes I did since the 5.4 release stable
Manuel Jacob <me@manueljacob.de> [Tue, 21 Jul 2020 01:04:19 +0200] rev 45191
relnotes: add release notes for relevant changes I did since the 5.4 release After having written the notes, I realized that the added points contain changes that were part of the 5.4.2 release. These were never included in any release notes. I asked on IRC whether they should be added to this file or not, but didn’t get an answer to this question. If they should not be added here, I can remove them. Differential Revision: https://phab.mercurial-scm.org/D8770
Mon, 20 Jul 2020 18:04:19 +0200 relnotes: fix indentation stable
Manuel Jacob <me@manueljacob.de> [Mon, 20 Jul 2020 18:04:19 +0200] rev 45190
relnotes: fix indentation The two points were written by me. For some reason, I missed the fact that the other points were indented by one space. Differential Revision: https://phab.mercurial-scm.org/D8769
Mon, 20 Jul 2020 17:57:31 +0200 relnotes: make spacing before new section consistent stable
Manuel Jacob <me@manueljacob.de> [Mon, 20 Jul 2020 17:57:31 +0200] rev 45189
relnotes: make spacing before new section consistent Differential Revision: https://phab.mercurial-scm.org/D8768
Wed, 22 Jul 2020 14:58:49 +0530 tests: make one of 'worker process exited' line option in test-chg.t stable
Pulkit Goyal <7895pulkit@gmail.com> [Wed, 22 Jul 2020 14:58:49 +0530] rev 45188
tests: make one of 'worker process exited' line option in test-chg.t I investigated and it seems like under high load, the child process is already there and no new fork was created. Hence the process was not closed.
Wed, 22 Apr 2020 18:08:12 -0400 infinitepush: fix `{get,put}_args` formatting on Python 3 stable
Connor Sheehan <sheehan@mozilla.com> [Wed, 22 Apr 2020 18:08:12 -0400] rev 45187
infinitepush: fix `{get,put}_args` formatting on Python 3 Calling `.format()` on a byte-string does not work, thus causing an exception on Python 3. This commit adds a function to paper over the difference. Differential Revision: https://phab.mercurial-scm.org/D8781
Wed, 22 Apr 2020 17:59:17 -0400 infinitepush: replace `NamedTemporaryFile` with `pycompat.namedtempfile` stable
Connor Sheehan <sheehan@mozilla.com> [Wed, 22 Apr 2020 17:59:17 -0400] rev 45186
infinitepush: replace `NamedTemporaryFile` with `pycompat.namedtempfile` Fixes a Python 3 compat error when using the external bundle store. Differential Revision: https://phab.mercurial-scm.org/D8780
Mon, 20 Jul 2020 20:31:24 +0900 chgserver: discard buffered output before restoring fds (issue6207) stable
Yuya Nishihara <yuya@tcha.org> [Mon, 20 Jul 2020 20:31:24 +0900] rev 45185
chgserver: discard buffered output before restoring fds (issue6207) On Python 3, flush() appears not discarding buffered data on EPIPE, and the buffered data will be carried over to the restored stdout.
Tue, 21 Jul 2020 20:49:05 +0900 hghave: fix possible int('') in has_clang_format() stable
Yuya Nishihara <yuya@tcha.org> [Tue, 21 Jul 2020 20:49:05 +0900] rev 45184
hghave: fix possible int('') in has_clang_format()
Mon, 20 Jul 2020 22:16:26 +0530 Added signature for changeset 28163c5de797 stable
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 20 Jul 2020 22:16:26 +0530] rev 45183
Added signature for changeset 28163c5de797
Mon, 20 Jul 2020 22:16:13 +0530 Added tag 5.5rc0 for changeset 28163c5de797 stable
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 20 Jul 2020 22:16:13 +0530] rev 45182
Added tag 5.5rc0 for changeset 28163c5de797
Mon, 20 Jul 2020 21:56:27 +0530 merge default into stable for 5.5rc0 stable 5.5rc0
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 20 Jul 2020 21:56:27 +0530] rev 45181
merge default into stable for 5.5rc0
Sat, 18 Jul 2020 18:38:46 +0900 phases: move short-lived PyObject pointers to local scope
Yuya Nishihara <yuya@tcha.org> [Sat, 18 Jul 2020 18:38:46 +0900] rev 45180
phases: move short-lived PyObject pointers to local scope It helps understand which object should be decrefed on goto release.
Sat, 18 Jul 2020 18:35:17 +0900 phases: rename variable used for owned dict of phasesets
Yuya Nishihara <yuya@tcha.org> [Sat, 18 Jul 2020 18:35:17 +0900] rev 45179
phases: rename variable used for owned dict of phasesets The phaseroots variable is used for two different objects: borrowed set and owned dict of sets. It's hard to track which object should have to be decrefed on error return.
Sat, 18 Jul 2020 18:27:39 +0900 phases: leverage Py_BuildValue() to build PyInt and steal PyObject
Yuya Nishihara <yuya@tcha.org> [Sat, 18 Jul 2020 18:27:39 +0900] rev 45178
phases: leverage Py_BuildValue() to build PyInt and steal PyObject "N" means "O" without incref, so we can just return the created tuple.
Sat, 18 Jul 2020 18:21:26 +0900 phases: make sure an exception should be set on error return
Yuya Nishihara <yuya@tcha.org> [Sat, 18 Jul 2020 18:21:26 +0900] rev 45177
phases: make sure an exception should be set on error return This should never happen, but the code looks wrong without PyErr_Set*() call.
(0) -30000 -10000 -3000 -1000 -300 -100 -50 -24 +24 +50 +100 +300 +1000 +3000 tip