Matt Mackall <mpm@selenic.com> [Mon, 01 Jun 2009 13:51:21 -0500] rev 8698
fetch: no need to pass files list to commit
Marco Beck <mbeck@miamod.de> [Wed, 03 Jun 2009 14:50:03 +0200] rev 8697
templater: retain author's full name if no email is supplied (
issue1685)
Dirkjan Ochtman <dirkjan@ochtman.nl> [Wed, 03 Jun 2009 14:10:36 +0200] rev 8696
tests: delete parallel coverage files after combining
John Mulligan <phlogistonjohn@asynchrono.us> [Wed, 03 Jun 2009 13:59:38 +0200] rev 8695
heads: show closed heads only when --closed is passed
Add a --closed (-c) option to 'hg heads' to show all heads and change the
default behavior to refrain from showing fully closed branches.
Enhance 'hg heads <branch>' so that:
* default: displays normal & inactive heads, not closed heads
* --closed: displays normal, inactive & closed heads
* --active: displays only normal heads
* both --closed and --active: displays normal & closed heads only
John Mulligan <phlogistonjohn@asynchrono.us> [Wed, 03 Jun 2009 13:42:55 +0200] rev 8694
localrepo: set heads and branchheads to be closed=False by default
The heads(...) and branchheads(...) functions will now only return closed
heads when explicitly asked for them. This will cause 'hg merge' to have
better behavior in the presence of a branch that has closed heads when no
explicit rev is passed.
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:42 +0200] rev 8693
convert: rewrite tags when converting from hg to hg
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:41 +0200] rev 8692
convert: default revisions order depends on source
When converting Mercurial repositories you expect the revision numbers to be
preserved, while other sources conversions focus on efficiency.
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:39 +0200] rev 8691
convert: fail fast if source does not support --sourcesort
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:39 +0200] rev 8690
convert: add --sourcesort option for source specific sort
Only supported by Mercurial source for now.
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:38 +0200] rev 8689
convert: parse sort mode sooner
Patrick Mezard <pmezard@gmail.com> [Mon, 01 Jun 2009 17:12:37 +0200] rev 8688
convert: split toposort() into subfunctions for readability
Greg Ward <greg-hg@gerg.ca> [Mon, 01 Jun 2009 09:18:35 -0400] rev 8687
run-tests: don't replace PYTHONPATH, just augment it.
(Needed at least for Subversion bindings on OS X, which are in
/opt/subversion. Useful for other external libraries installed in
non-standard places too.)
Martin Geisler <mg@lazybytes.net> [Mon, 01 Jun 2009 01:24:01 +0200] rev 8686
merge with mpm
Martin Geisler <mg@lazybytes.net> [Mon, 01 Jun 2009 00:56:29 +0200] rev 8685
color: yet another typo
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8684
match: fold plan cases down to two special cases
- merge always and match with patterns
- make always and match with patterns the default
- invert dostep3 to skipstep3
- move dirignore test inside exact case
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8683
walk: refactor walk plan
- never is gone
- reorder tests more cleanly
- rename nomatches to exact for clearer semantics
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8682
match: remove match.never
Only one user, can be translated to match.exact()
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8681
walk: use match.bad callback for filetype messages
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8680
match: ignore return of match.bad
All users returned false, return can now be dropped
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8679
add: use match.bad callback more effectively
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8678
match: document bad callback semantics
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8677
walk: simplify logic for badfn clause
- matchfn redundant
- call badfn always rather than fwarn
- use for/else rather than keep var
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8676
walk: we always have a badfn
Matt Mackall <mpm@selenic.com> [Sun, 31 May 2009 17:54:18 -0500] rev 8675
walk: simplify check for missing file