crecord: rewrite a comment about filtering patches
I couldn't parse the previous version. I think the rewrite better
expresses the intent of that comment.
run-tests: teach _processoutput to handle multiple lines of churn
Instead of treating expected output as happening in a precise order,
and assuming that if a line is missing it will never happen,
assume that expected output is a prioritized list of likely matching
lines.
This means that if:
foo/bar (glob)
baz/bad (glob)
changes to:
baz/bad
foo/bar
instead of generating:
baz/bad
foo/bar
For which we've lost both (glob) markers,
we will match both lines and generate:
baz/bad (glob)
foo/bar (glob)
This retains any special annotations we have for lines.
run-tests: indent _processoutput to aid readability for next patch
The next commit will loop over the expected[pos] list, this change
makes that change easier to review.
tests: add test for "log -r wdir() -p" (
issue4871)
The issue has been fixed by
93bcc73df8d5, "cmdutil.changeset_printer: pass
context into showpatch()". This patch adds test to prevent future regression.
tests: include modified/added/removed files in "log -r wdir()" output
This patch prepares for the test of "hg log -r wdir() -p".